[PCem] Windows 98-Emulator (v15)
1
(20.05.2019, 18:17)Cebion schrieb:
(20.05.2019, 17:06)Andi schrieb:
(20.05.2019, 08:08)donald schrieb:
(19.05.2019, 21:14)Andi schrieb: Update auf V15. Siehe: PcEm

Hi,

danke für die Info.

QEMU 4.0 gibt es mittlerweile schon, da werde ich auch einen erneuten Versuch starten.

Gerne. V15 schon probiert? "CPU time" der neuen Version ist bei mir etwa 20% geringer. Hätte etwas mehr erwartet, aber immerhin wird im Forum auch erwähnt, dass noch es noch einige Verbesserungen geben wird.

Was heißt CPU time?

Du weißt ja, dass die Emulationsgeschwindigkeit (grün) bei 100% sein sollte, da PCem ansonsten nicht mehr flüssig läuft und stottert, nicht? Am blauen Wert kannst du sehen, wie weit entfernt du davon bist, dass dieser Fall eintritt. Je niedriger "CPU time" ist, desto besser. Erreicht dieser Wert allerdings 100%... tja, dann fällt die Emulationsgeschwindigkeit (grün) und es beginnt zu ruckeln. Ist also ziemlich aufschlussreich.

(Diese Anzeige kann man unter Misc -> Machine -> Options -> Status aktivieren)
[Bild: ghghjw5k6x.jpg]
Zitieren
1
Wieder was gelernt!
Danke dir
[Bild: 5dnx1syg1tc.jpg]
I am Guybrush Threepwood, mighty Pirate!

[Bild: general-small.png]
Cebion's Adventure Corner! Adventures von 1986-2000
Zitieren
1
Hi,

@Andi
von solchen Werten kann ich bei meinem alten System nur träumen.
Ich mache das eigendlich von Spielen abhängig, die nicht so richtig rund laufen.
Habe mir jetzt mal in einer Win98SE Installation "Die Legende des Propheten und des Mörders" angespielt. Es läuft mit 32 Bit Farben recht anständig.
Genommen habe ich einen Mobile Pentium MMX 233. War mit der v14 nicht dran zu denken.
Zitieren
0
(04.01.2019, 03:12)K.A.R.R. schrieb:
Glurak schrieb:Muss ich erst noch treiber installieren damit ich diese Sound Einstellung nutzen kann?


yep da mus noch der "sb pci 128" treiber installiert werden.

zum installieren des neusten treibers braucht man auch noch nen w98se cd !
(ne dt iso findet man z.b. auf winworldpc)


mit der sb 128 hast du auch noch den vorteil, im w98 mixer nen extra volumen
regler für die audio cd wiedergabe zu haben.
zudem gibts bei creative noch nen 8mb soundfont für die midi wiedergabe.




hier in dem paket ist der neuste treiber und der 8mb creative soundfont für die midi wiedergabe.



Sound Blaster PCI (WDM) Drivers V 5.12.01.5017

Dateiname : SBPCI_WebDrvsV5_12_01.exe Overview This package is meant for Sound Blaster® Vibra128, Sound Blaster 16 PCI, Sound Blaster PCI 128, Sound Blaster 4.1 Digital, and Sound Blaster Ensoniq AudioPCI users running Windows 98SE, Windows ME, Windows 2000 and Windows XP, who experienced distortion problem when playing a wave or MP3 file in 4 speaker mode. For PRODIKEYS™ users who are running on Windows 98SE, this Web Update will enable them to record and playback under IMPRESS mode within the PRODIKEYS application. The package will contain the following:  Sound Blaster PCI (WDM) Drivers V 5.12.01.5017 Requirements An existing Sound Blaster Vibra128, Sound Blaster 16 PCI, Sound Blaster PCI 128, Sound Blaster Ensoniq AudioPCI, or Sound Blaster PCI4.1 Digital software package must be installed before installing this update.  Notes      Creative Configurator works with VXD drivers only. The Creative Configurator program link in the Start Menu will be removed after users install the Web Update.     For users who are running Windows 98SE, this Web Update will upgrade VXD drivers to WDM drivers.     This release works with the CT4816, CT4751, CT5808, CT4740 and the CT4815.     This package is not applicable to model CT4730 2-channel audio card. Installation WILL NOT proceed.

(nen alten treiber braucht man nicht vorher, so wie creative da sagt)





hier nun ne anleitung wie man am besten vorgeht
(gehe mal davon aus du nutzt die w98 version von andi)


zuerst w98se booten und dort im geräte manager die alte wss soundkarte
entfernen
(systemsteuerung > system > geräte manager > audio video gamecontroller)
ms windows sound system kompatibles gerät
(die wss sound blaster emulation verschwindet automatisch mit)
den gameport braucht man nicht zu löschen, auch wenn die sb128 nen eigenen mitbringt, hat man später 2, egal ob man den entfernt oder nicht)

danach w98se runterfahren.
nun den treiber und die soundfont datei aus meinem paket auf das w98se festplatten image packen z.b in nen ordner "sb128".
danach pcem starten und dort die soundkarte auf die soundblaster pci 128 ändern.

nun w98se booten.
bei der frage nach nem treiber für das neue multimedia gerät auf abbrechen klicken.

nun einfach den treiber "SBPCI_WebDrvsV5_12_01.exe" installieren.
bei der frage nach der w98se cd, einfach unter pcem das image "einlegen".
(beim image von winworldpc zum ordner w98 auf der cd wechseln).
bei der frage nach der ksuser.dll und der stream.sys die neuere datei beibehalten auswählen.
danach w98se wie gewünscht neu booten (je nachdem wie schnell man da druf geklickt hat,
wird der gameport der sb128 vor oder nach dem neu booten gefunden)
eventuell wird nochmal nach der w98se cd gefragt.

die sb128 ist nun installiert, nun noch den 8mb soundfont für die midi wiedergabe auswählen.
dazu wieder in den geräte manager gehn und auf SB PCI (WDM) klicken
oben auf settings und dann bei MIDI Synthesizer Waveset das 2mb set durch
eapci8m.ecw ersetzen.
beim klicken auf ok friert das system für ca 30 sec ein, da der soundfont geladen wird.
(wird nur einmal gemacht).


fertig  Elefant


ps: ich nutz auch die sb128 statt dem wss unter w98.



bei creative findet man auch noch vers tools wie z.b
den creative mixer, recorder und playcenter.

https://support.creative.com

sound blaster auswählen, dann unten bei "Wenn Ihr Produkt nicht aufgelistet ist klicken Sie bitte hier" drauf klicken. nun im linken reiter auf "other" klicken dann im rechten reiter runter scrollen bis zu "sound blaster pci 128" und auf weiter klicken. nun ganz unten bei manuelle auswahl "windows 98se" auswählen und auf senden klicken.


braucht man aber idr nicht, da man was den mixer angeht, alles bei dem von w98 dabei hat.

Magst du das nochmal reuppen ?  Finde die Datei auf meinem Rechner nicht mehr und brauche wieder für V15 :-D
Zitieren
0
ah noch gar nicht gesehn das es nun v15 gibt Big Grin 


joa ich such mal und lads später wieder hoch

edit:
hier das treiber paket

Sound Blaster PCI (WDM) Drivers V 5.12.01.5017
Zitieren
0
Ist das normal das eine Festplatte nach dem bloßen Kopieren/Umbennen der Konfig im Manager nicht mehr erkannt wird?
Hatte vorher schon Images die ich ursprünglich in 86box angelegt habe die nicht mehr wollten, dachte mir aber, das könnten irgendwelche Veränderungen bei PCEem sein.
Jetzt habe ich aber folgendes bei PCem:
Ein Festplattenimage mit DOS 5.0 und Geoworks Ensemble bespielt, bootet unter der ursprünglichen Konfig "386 DX".

Habe dann mal die CPU auf einen 486 SX gestellt, und trotz Erkennung im BIOS wollte die nicht mehr.

Mal die ursprüngliche funktionierende Konfig kopiert und in "Geoworks" umbenannt. Bis auf den Namen identisch, booten tut aber nur "386 DX", unter der anderen kommt "Missing operating system".
Zitieren
0
Hi,

könnte es sein, dass deine Partition zu groß ist?

Du hast ja das Motherboard gewechselt und das Bios ist für die maximale Festplattengröße (Partition) zustandig.
Bei FAT16 ist die maximale Größe 2 GB. Vielleicht etwas drunter bleiben so 1999 MB versuchen?
Ich benutze Nortons Ghost Disk Image um ein Betriebssystem auf eine kleinere/großere Festplatte zu kopieren. Voraussetzung sind 2 HD Images in PCem.
Zitieren
0
Hehe, nein, das Abbild ist 68 MB groß. Wurde auch mit PCem erzeugt.

Wie geschrieben, alleine das Kopieren oder Umbenennen der Konfiguration macht das Image nicht mehr bootbar.

Habe gerade ein anderes Festplattenimage mit Win 3.1 getestet, und das funktioniert einwandfrei wenn man kopiert, die Maschine ändert etc.)

Das Geoworks Image läßt sich auch unter DOSBox booten (ging mit S3 SVGA, unter PCem hatte ich die Tseng 4000 eingestellt) aber warum das solche Probleme mit PCem macht ist mir schleierhaft.
Habe es mal hochgeladen:

http://www.mediafire.com/file/24y86pd46q...nsemble.7z
Zitieren
2
Hi,

PCem hat das Image in 1024 Cyl., 8 Heads, 17 Sec. eingeteilt.

Du solltest den LBA Modus bei der Festplattenerkennung auswählen können. Dann bootet das Image, wenn denn dann der LBA Modus zur Verfügung steht.
LBA -> 69 Cyl., 32 Heads, 63 Sec.

Ich mache meine RAW Images mit der Daum-DOSBox -> imgmount c .\geo.img -t hd -size 68 -bat. Unter 2 GB sind die Images partitioniert und formatiert.
In PCem ist das Image mit 138 Cyl., 16 Heads, 63 Sec. eingetragen. (PCem ist doof!)
Die DOSBox sagt 552 Cyl., 4 Heads, 63 Sec.
Diese Werte musst du in den anderen Motherboards eintragen.

Habe so ein Image erstellt, mit Ghost ein Backup von deinem Geo gemacht und in das neue Image übertragen. Es sollte nun in verschiedenen Boads laufen.

https://1fichier.com/?01cussj2kaoz3y2sbxbl
Zitieren
0
Tatsache, funzt. Vielen Dank!
Zitieren
0
Hallo,
welche CPU-Leistung kann man mit PCem-ulieren? Gerade wie ich lese, dass 3dfx emuliert werden kann, stellt sich mir die Frage, ob die Klassiker der 3dfx Zeit mit diesem Emulator flüssig machbar sind.

Danke, Gruß
Zitieren
1
Momentan ist dieser Bereich abgedeckt:

[Bild: dfdfbfjvj.png]
Zitieren
1
und beim amd gehts je nach board bis zum k6-2+ 550 und k6-3+ 500 hoch und beim cyrix bis zum cyrix 6x86mr pr400.


beim pcem v14 konnte ich mit meinem alten intel i5 4670
windows 95 mit nem p166 mmx incl. einer voodoo 2 ohne probleme emulieren.
sogar nfs porsche lief damit.

mit pcem v15 geht sicher noch bissel mehr, da es dort nen neuen cpu recompiler gibt.
Zitieren
0
Gibt einige Titel die mir spontan einfallen, die ich mal testen würde. Die Starfleed Academy DVD sowie von Tex Murphy Overseer die DVD Edition.
Zitieren
1
Update:

- aktuelles Romset hinzugefügt (danke, @K.A.R.R.!)
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste