[Remake] Ambermoon.NET
#1
3
Wie der Name vermuten lässt, ist Ambermoon.NET eine Remakeversion (OpenSource) des gleichnamigen Amigaspiels.

Spielbar für Windows, Linux und Mac

https://www.pyrdacor.net/
DL: https://github.com/pyrdacor/ambermoon.net

Ich habe die standalone Version von Linux runtergeladen, das zip enthält außer der ausführbaren Spieldatei ein Handbuch (eng), die dazugehörige Ambermoon-Karte und eine Runentabelle.

Eine Erweiterung (Ambermoon Advanced) ist noch in Arbeit.
Ambermoon.NET ist wahlweise in deutscher oder englischer Sprache spielbar.

[Bild: ambermoon.net11uk8q.png]

Weitere Screenshots sind auf der Projektseite.

Edit:
Wer sich für die Originaldateien usw. interessiert, der kann sich auf der nächsten Seite umsehen. Wink
https://github.com/Pyrdacor/Ambermoon
[Bild: sigkryeu.gif]
Dt. Text-Patch für die Uncut-Version von ›IHNMIMS‹
http://ihnm.blogspot.comThread
Zitieren
#2
0
So, habe das .net Framework 4.7.1 sowie die Windows 64 Bit UND die Windows exe installiert... beides unter Win 7. Starten tut es nicht, auch Lopez Version startet nicht. Was mache ich falsch?

Im Verzeichniss liegt die Ambermoon.net-Version mit 88 Mb Größe.
Zitieren
#3
0
Wieso Lopez Version?

Gehe auf https://github.com/pyrdacor/ambermoon.net
Scrolle runter zu „Download“ und lade die Standalone-Version von Windows herunter, und entpacke das Zeug in einen leeren Ordner.
Aber da du .NET hast sollte die „Size-Optimized“-Version genügen.

Du brauchst kein Ambermoon von Amiga oder so (glaube ich zumindest).

Edit:
Die Standalone Ambermoon.net.exe hat 88 MB, die ohne .NET-Bibliotheken 22,5 MB.
Da muss jemand mit Windows testen, ich habe keines.
[Bild: sigkryeu.gif]
Dt. Text-Patch für die Uncut-Version von ›IHNMIMS‹
http://ihnm.blogspot.comThread
Zitieren
#4
0
Geht hier nicht... Lopez hat doch so ein Megapaket geschnürt... Habe auch die ADF's mit reingepackt, hatte auch keinen Effekt...
Zitieren
#5
0
Bei mir geht die 64-Bit Standalone auf Win 8.1. Allerdings öffnet sich beim ersten Laden erst ein kleines Fenster auf Befehlsebene, wo sich ca. 30 Sek gar nichts tut, dann öffnet sich ein größeres weißes Fenster, wo sich ebenfalls 20 Sek. Nix tut und dann kommt es.

Bei jedem Neustart ist es dann aber sofort da.

Also vielleicht etwas Geduld aufbringen.

Mit F11 kommt man in den Vollbild-Modus. Leider springen einem dann die harten Pixel entgegen.

Gibt es evtl. Shader, Filter oder irgendwas, um da nicht Augenkrebs zu bekommen? Auf größeren Monitoren ist die Schrift daher schlecht zu lesen.
Zitieren
#6
0
(29.08.2021, 05:48)Commodus schrieb: Mit F11 kommt man in den Vollbild-Modus. Leider springen einem dann die harten Pixel entgegen.

Gibt es evtl. Shader, Filter oder irgendwas, um da nicht Augenkrebs zu bekommen? Auf größeren Monitoren ist die Schrift daher schlecht zu lesen.
In den Optionen gibt es die Möglichkeit Einstellungen vorzunehmen.
Spielbildschirm → Enter; rechts auf das Diskettensymbol → OPT → Pfeil zum weiterschalten

Die Einstellungen werden in der Datei ambermoon.cfg gespeichert, siehe
https://github.com/Pyrdacor/Ambermoon.ne...uration.md

Wer im Forum auf mightandmagicworld.de registriert ist, kann ja dort nachfragen.
Pyrdacor – der Autor des Programms – hat dort sein Remake vorgestellt.
https://www.mightandmagicworld.de/phpbb/...679#407679
[Bild: sigkryeu.gif]
Dt. Text-Patch für die Uncut-Version von ›IHNMIMS‹
http://ihnm.blogspot.comThread
Zitieren
#7
0
Danke Mustrum. Der Grafikfilter hilft nur eingeschränkt, aber trotzdem toll, das Ambermoon nun auch auf dem PC ohne Emulator spielbar ist.
Zitieren
#8
0
Verfolge das Projekt in den letzten Monaten sehr genau. Die Releasefassung sollte ja eigentlich noch im August erscheinen. Was aber da ist (momentan noch Test Release genannt), ist praktisch schon das ganze Spiel. Ich finde es grossartig, was Pyrdacor hier geleistet hat. Das Spiel entspricht praktisch 1:1 dem Original (das ich vor einigen Wochen zuende gespielt habe), verbessert das Erlebnis aber dezent - was v.a. bei diversen Bugfixes, aber auch ganz auffällig bei den 3D-Sequenzen deutlich wird. Gerade diese lassen sich jetzt perfekt steuern. Die Standalone startet bei mir ohne Anstalten, vielleicht mal Pyrdacor kontaktieren, wenn dem nicht so ist? Der freut sich über jede Nachricht.

@Mustrum Weil lopez72 Ambermoon.net (eine frühere Version) in seinem grossartigen Ambermoon-Paket mit eingeschnürt hat.

edit: ach nein, das ist ja tatsächlich die 1.0! Ich war immer beiden Test Releases am schauen, deswegen habe ich's gar nicht bemerkt. Big Grin
Zitieren
#9
0
Also bei mir geht es nicht, keine der genannten Versionen unter Win 7. Mal sehen, vielleicht melde ich mich mal beim Pyrdacor...

Es kommt lediglich eine CLI bzw. DOS-Fenster, was aber ganz fix wieder verschwindet, es steht jedoch etwas drin, nur was...?
Zitieren
#10
0
(29.08.2021, 12:44)muetzeglatze schrieb: Also bei mir geht es nicht, keine der genannten Versionen unter Win 7. Mal sehen, vielleicht melde ich mich mal beim Pyrdacor...

Es kommt lediglich eine CLI bzw. DOS-Fenster, was aber ganz fix wieder verschwindet, es steht jedoch etwas drin, nur was...?
Ich hatte dasselbe Problem, allerdings nur, wenn ich die 32bit-Version genommen hatte.

edit: schau mal hier bei den Kommentaren auf indieretronews, da hat eine Nutzerin Penelope Jenga dasselbe Problem. Scheint bei ihr was mit dem Grafikkartentreiber zu tun gehabt zu haben.
Zitieren
#11
0
(29.08.2021, 12:46)Prometheus schrieb:
(29.08.2021, 12:44)muetzeglatze schrieb: Also bei mir geht es nicht, keine der genannten Versionen unter Win 7. Mal sehen, vielleicht melde ich mich mal beim Pyrdacor...

Es kommt lediglich eine CLI bzw. DOS-Fenster, was aber ganz fix wieder verschwindet, es steht jedoch etwas drin, nur was...?
Ich hatte dasselbe Problem, allerdings nur, wenn ich die 32bit-Version genommen hatte.

edit: schau mal hier bei den Kommentaren auf indieretronews, da hat eine Nutzerin Penelope Jenga dasselbe Problem. Scheint bei ihr was mit dem Grafikkartentreiber zu tun gehabt zu haben.
Also, ich habe die Windows 64 Bit Standalone-Version geladen, gleicher Fehler...

OK, dann scheints an der Grafikkarte zu liegen.
Zitieren
#12
0
Hier auch..Win7 64Bit. Startet nicht Sad
Zitieren
#13
0
Das scheint unter Windows eventuell an der Hardware (Intel) und der damit (nicht) unterstützenden aktuellen OpenGL zu liegen.

https://github.com/Pyrdacor/Ambermoon.net/issues/182
[Bild: sigkryeu.gif]
Dt. Text-Patch für die Uncut-Version von ›IHNMIMS‹
http://ihnm.blogspot.comThread
Zitieren
#14
0
Bei mir mit Win7 64Bit Standalone Startet normal wie gewohnt. Die 32Bit Standalone Fassung bricht mit Fatal Error 0xC000005 at Silk.NET.GLFW.Pollevents ab
Programmierer sind gefährliche Waffen. Deshalb ist es Ihnen Gesetzlich verboten sich frei zubewegen (GitS)

Teufel Amiga: The Computer They Couldn't kill Teufel
Zitieren
#15
0
Die Amiga Version wurde übrigens auch auf v1.09 aktualisiert.

https://github.com/Pyrdacor/Ambermoon
Awards für außergewöhnlich gute oder lustige Threads/Posts:

1. Gadler = für sein wasserdichtes "Wie suche ich richtig" Tutorial.
Zitieren
#16
0
Wenn's nicht läuft unter Windows: Die gepatchte Amiga-Version spielt sich ja praktisch identisch mit dem PC-Port. Der einzige fühlbare Unterschied betrifft die 3D-Sequenzen, die unter Windows flüssiger und einfacher zu steuern sind. Man verliert also nicht so viel, wenn man statt der Windows- die Amiga-Version mit WinUAE spielt (ich habe das Spiel letztens in Pyrdacors Version mit WinUAE durchgespielt und sehr genossen).
Zitieren
#17
0
(11.09.2021, 03:39)Retro-Nerd schrieb: Die Amiga Version wurde übrigens auch auf v1.09 aktualisiert.

https://github.com/Pyrdacor/Ambermoon
Vielen Dank für den Hinweis. Gleich mal mein HDF-File geupdated.

Jetzt kann ich also erst spielen.

Kurze Frage noch zu Ambermoon via FS-UAE Emulator.

Ambermoon startet bei mir nicht bei Konfiguration A4000. Was muss ich dafür einstellen?
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste